nem programoz az stk200

Hogyan programozzak AVR chipet? Programozók beállításai...
Bascom nyelvű programok...
viktor

nem programoz az stk200

HozzászólásSzerző: viktor » 2006. november 21. kedd, 12:15

sziasztok. vettem 1 stk200-at,de nem sikerül vele programoznom. leforditom a ledvillogtató programot. szimulálni is tudom,de mikor le akarom tölteni a chipre,nem sikerül.
a következöképpen csináltam: rádugtam az stk200-at a nyomtatóportra. az stk 200at összekötöttem az oldalrol rendelt probapanellal a programozókábellel,majd elinditom a letöltést,s mindig bejön v.mi ablak ahol hexadecimális kódok vannak (azt hiszem a programozónak valami beállitási ablaka.) eddig jutottam. a bascom könyvben olvasottak szerint beállitottam amit kell(4-5 fejezet). a tápkábelt nem dugtam rá a probapanelra. nem tudom,kellett volna e? nem nagyon foglalkoztam még programozással,ugyhogy,kellene 1 kis segitség az induláshoz.

Avatar
Masterfoxx
DrótVégénSzéndarab
Hozzászólások: 37
Csatlakozott: 2006. január 4. szerda, 7:00

HozzászólásSzerző: Masterfoxx » 2006. november 21. kedd, 16:25

Tápfeszültség azért kell neki.... Anélkül nem megy.... :D

Avatar
Robert
Elektronbűvölő
Hozzászólások: 10084
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2006. november 22. szerda, 5:35

Nem a föld változó mágneses teréről jár:). Tessék neki tápot adni. Onnan veszi a STK200 is a saját tápfeszjét.

Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 19:44

ATMEGA16-ot programoznék a kézikönyvben leírt kapcsolással (74HC244).
BASCOM-ban a gyári port kiosztást írtam be (a nyákot is aszerint készítettem), a kvarc 8 megás.
A programmerben kiválasztottam az atmega16-ot és az Identify gomb lenyomására a következő üzenetet kaptam:
Could not identify chip with ID:FFFFF

Írni nem mertem bele, nem tudom, hogy kizárnám-e magam. Csak a read flash ROMparancsot próbáltam, de az eredménynek nem tudom, hogy minek kellene lennie.

A próba panelom nagyon egyszerű, miinden portot tüskére hoztam ki, valamint a PB4,5,6,7 portok mennek a programozóhoz.
Tud valaki tanácsot adni? :roll:

Avatar
Robert
Elektronbűvölő
Hozzászólások: 10084
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2007. január 12. péntek, 19:56

Táp van a chipen és a 74244-en?
A Bascomban a programozónak kiválasztottad a STK200-at?
LPT port jól be van állítva?
Igaz nem USB-LPT átalakítót használst? Amúgy érdemes megnézni a társtopicot, ott eléggé körbe lett járva...

Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 20:08

kösz a gyors reagálást.
táp próba panelon 7805. ez megy a 74hc244-re is. chip berakás előtt feszültséget elleőriztem ésaz összes portot "lelámpáztam". a portb-re dugott ledsor villog a kommunikáció esetén. kvarc nyolc megás. a atmel bekötését (reset, kvarc, és programozás) a megaboard-ról koppintottam. a ponyprog sem ismeri fel, de a reset az mükszik mindkét proginál. a tápfeszre az "égetőn" nagyon vigyázok. olvastam a kizárásos topikot.
remélem nem nyírtam ki valahogy?
a programozó maradhat a kártyán, ha leveszem a tápfeszt? a LPT kábel csatlakoztatva maradna.
A hozzászólást 1 alkalommal szerkesztették, utoljára HG6IRA 2007. január 12. péntek, 20:14-kor.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 10084
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2007. január 12. péntek, 20:13

MoSi, MiSo, SCK bekotest szoktak elkotni.
Alapban a chip a belso 1 MHzrol jar.
Amire vigyazz: A kulso 8 MHz-s kvarccal a PC sorosport nem mukodik egyutt!

Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 20:16

Robert írta:MoSi, MiSo, SCK bekotest szoktak elkotni.
Alapban a chip a belso 1 MHzrol jar.
Amire vigyazz: A kulso 8 MHz-s kvarccal a PC sorosport nem mukodik egyutt!


Az STK200 a direkt LPT-re van kötve. Nincs benne semmi más. A kötést ellenőrzöm.

Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 20:24

van az SS kimenet a PB4-en. az az égetőbe nem megy sehova.
Leellenőriztem. Minden rendben van, elkötés nincs.
a bascomban a hardveres programozó kapcvsolót be kell kapcsolni?

Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 20:30

ki vettem a kvarcot.
Communications-nál baudrate 0 57600, frekvencia 1 MHz.
Így sem ismeri fel.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 10084
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2007. január 12. péntek, 20:59


Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 21:29

Robert írta:NEM ott kell állítani.

http://avr.tavir.hu/modules.php?name=Co ... page&pid=6


elolvastam, a szerint jártam el.

Konkrétan a ponyprog oldalán található égetőt készytettemel. ott volt soros ellenállás 1 kOhm. a boltban sikeresen félre értettek és 10 k.sat kaptam, aztán nem ellenőriztem le a boltost. elméletileg áram nagyon minimális folyik, tehát az ellenálláson eső feszültség elhanyagolható. próba panelon a portra rakott led erőteljesen világít.

nem is meri fel a chippet. a tartalékot nem merem belerakni. van még ötleted?

Avatar
Robert
Elektronbűvölő
Hozzászólások: 10084
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2007. január 12. péntek, 21:52

A Ponyprog oldalan levovel mar megszivtam. A 10 k hol van? NEM kell bele, ld a http://avr.tavir.hu/modules.php?name=Co ... page&pid=6 oldalon az utolsó ábrát. Ha 5Vos a rendszer, akkor a felette levő tisztán kábelessel próbáld meg.
Ja, a kábel NE legyen hosszabb 20-25 cmnel!
A 244-es esetén is tartsd be a 20 cm-t!
Tápot mérd meg a 244-en, illetve a áramkörben. A 5V és a GND-k rendben? A chipen a Vcc és a Vcc analóg és a GND, GND analóg is be van kötve?
A MOSI, MISO, SCK, Reset lábakon NE legyen kapacitív terhelés, sőt a MOSI, MISo, SCK lábakon SEMMI más ne legyen!

Avatar
HG6IRA
DrótVégénSzéndarab
Hozzászólások: 18
Csatlakozott: 2007. január 11. csütörtök, 7:00
Tartózkodási hely: Debrecen

HozzászólásSzerző: HG6IRA » 2007. január 12. péntek, 22:14

a ponyprogosba van egy soros tápdióda, kiszedem, mert az ic-n a fesz 4,2 volt.
ezután sem megy. az kont. 4,5-5 között kap, annak ellenére, hogy a bemeneti fesz a 7805-re 11volt.

az programozó -> atmega = 20 cm szalagvez
lpt prot -> programozó szabványos printerhosszabító kábel 1 m

Avatar
Robert
Elektronbűvölő
Hozzászólások: 10084
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2007. január 12. péntek, 22:34

A 244-es nagysebességű?
A sima kébellel hogy megy?

Próbáld meg azzal....
A lptport BIOS beállítást tedd át sima IO-ra. A fórumban a disable pollingról írva van.
Más LPTbizgető progi igaz nincsen fenn? Pl. DirectIO, Port95NT, stb.


Vissza: “Bascom-AVR nyelvű programozás (AVR programozásának lehetőségei)”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég