Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX)

Ha a chip nem reagál a programozóra...
stenza
DrótVégénSzéndarab
Hozzászólások: 15
Csatlakozott: 2014. szeptember 18. csütörtök, 11:01

Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX)

HozzászólásSzerző: stenza » 2015. március 29. vasárnap, 13:18

Sziasztok!

Van egy Arudino Uno -m, ami nem hajlandó USB-n feljönni. Az L led világít, reset gombra nem reagál, usb-n nem jelenik meg.
Van egy TavIRISP STK500 programozóm is (http://shop.tavir.hu/product_info.php/p ... amozo-p-36).

Hogyan tudnám életre kelteni, ellenőrizni, hogy mi a fene van az Uno-val? Lehetőleg OSX-en, mert nincs Windows a környezetemben.


Amit próbáltam:
- Az Aduino IDE a legfrissebb, a TavirISP szépen látszik is, kiválasztom.
- Programmer: AVR ISP (gyári konfig, esetleg ezt kellene átírnom a TavIR-eshez?)

Eredmény:

Kód: Egész kijelölése

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

(sehol egy led villanás se)

TavIRisp STK500: v12
Arudino IDE: 1.6.2 (OSX)


köszönöm

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: Robert » 2015. március 29. vasárnap, 18:03

Szóval mi is lenne a kérdés?
- Arduino alól UNO programozás - nincs USB port?
- Minek ide a STK500 programozó?

Legújabb Arduino? 1.6.x?
- Azonnal törölni. Arduino 1.0.6 a stabil.

UNO: Mi az illesztőchip? FT232? ATMega16U2? ATMega8U2? CH340?


Szóval a mi a kérdés?

stenza
DrótVégénSzéndarab
Hozzászólások: 15
Csatlakozott: 2014. szeptember 18. csütörtök, 11:01

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: stenza » 2015. március 31. kedd, 22:44

Elnézést a pontatlanságért.

Szóval a helyzet, hogy van egy rendes Arduino Uno R3-am.
Működött is rendesen, és a vasárnapi napon újra rákötöttem a MAC-re, USB-n (ATMEG8U2) és se kép se hang.
Nem látszik a listában, nem látszik az USB eszközök közt.

A lap nem reagál a reset gombra sem, az L sárga led ég folyamatosan, haloványabban a power zöld led.
Állt 1 hónapot, de különösebb behatás nem érte.

Gondoltam hát az stk500-al vadi új bootloadert töltök rá, hátha.
És ezen a ponton akadt meg az egész a fentebbi hiba üzenetekkel.

Ebben kérnék egy kis segítséget.

Na de a kérdés:
OSX alól az STK500 segítségével, hogy töltsek rá fel új bootloadert / reseteljem / állapítsam meg, hogy kuka -e az UNO?
:(

köszönöm

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: Robert » 2015. április 1. szerda, 3:09

A chip bootloadere és az USB láthatósága két egymástól teljesen független dolog.
Az USB illesztést a Mega8U2 végzi. A Bootloader meg a ATMega328P chipbe kell.
Ha kiveszed a Mega328-at a tokjából, a PC oldalon akkor is látnod kell a panelt!

A Mega8U2-t ha nem indul el, akkor ismeretlen eszközként/nem azonosított eszközként akkor is látnod kellene...

Szóval KUKA.

stenza
DrótVégénSzéndarab
Hozzászólások: 15
Csatlakozott: 2014. szeptember 18. csütörtök, 11:01

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: stenza » 2015. április 1. szerda, 18:27

Hát ettől féltem.
Mindenesetre köszönöm.
:?

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: Robert » 2015. április 3. péntek, 8:13

Ismeretlen / nem azonosított / drivernélküli eszközként sem látszik?
Ha a nyákon alul átforrasztod a HWB jumpert, akkor sem jelenik meg?

stenza
DrótVégénSzéndarab
Hozzászólások: 15
Csatlakozott: 2014. szeptember 18. csütörtök, 11:01

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: stenza » 2015. április 6. hétfő, 13:57

Sajnos HWB-vel sem látszik, de úgy legalább a sárga led nem világított.

Kedden kipróbálom egy Win gépen.
Nincs meg a kellő jogosultságod a hozzászóláshoz csatolt állományok megtekintéséhez.

stenza
DrótVégénSzéndarab
Hozzászólások: 15
Csatlakozott: 2014. szeptember 18. csütörtök, 11:01

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: stenza » 2015. április 7. kedd, 18:35

Robert írta:Ismeretlen / nem azonosított / drivernélküli eszközként sem látszik?
Ha a nyákon alul átforrasztod a HWB jumpert, akkor sem jelenik meg?


Igazad volt, Win alatt látszik ismeretlen eszközként, BADDEVICE.Dev hardver tulajdonsággal.
A HWB sem változtatott ezen.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: Robert » 2015. április 7. kedd, 18:53

Baddevice: USB nem éled fel:
- sérült a kvarc
- sérült a rezonátor/kondi
- forrasztási hiba
- halott IC
- hibás USB csatlakozó...

stenza
DrótVégénSzéndarab
Hozzászólások: 15
Csatlakozott: 2014. szeptember 18. csütörtök, 11:01

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: stenza » 2015. április 7. kedd, 22:31

Szemrevételezéssel semmi nem látszik. Mást meg nem tudok vele kezdeni.

Köszönöm, hogy segítettél. Akkor mégis kuka :(

pused
Újonc
Újonc
Hozzászólások: 1
Csatlakozott: 2015. május 5. kedd, 18:20

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: pused » 2015. május 5. kedd, 18:50

Sziasztok.
Egy hetes uno r3 klonnal egy robotkar 3. servojat programoztam, mikor az x-dik program feltoltes utan egyszer csak a windows nem latta a vezerlokartyat. Hasonlo a jelenseg azert irok ide, mert az L led folyamatosan vilagit es semmire nem reagal. Akkor ahogy irjatok tenyleg eselytelen a dolog? Tuti hardware szallt el? Elvileg van ra egy honap gari. Biztos ami biztos ma megrendeltem a Maxi keszletet a tavIR webshopbol nem bizom ezek utan a klonokban. ☺
Elnezest az ekezet hianyert telefonrol irtam.

tambi
Újonc
Újonc
Hozzászólások: 9
Csatlakozott: 2015. május 5. kedd, 19:55

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: tambi » 2015. május 5. kedd, 20:44

Kedves Robert, tisztelt Fórumtársaim!

Segítségeteket kérem stk500 ügyben, mert hajlott korom ellenére hozzátok képest csupán nyeretlen kétéves vagyok. R3 + EXT1 készlet mellé stk500-t vásároltam azzal a szándékkal, hogy bootloader-telen AVR-t is tudjak programozni AVRStudio4.19 C++, és BASCOM-AVR alól. A WIN7 azonnal felteszi a portok közé "USB Serial Port (COMx)", valamint az USB Vezérlők közé "USB Serial Converter" néven. Hosszas utána olvasással sikerül a BASCOM-ban a sebességeket is állítgatva "stk500 nativ driver" néven felismertetni, illetve használni. Az ARDUINO1.0.5-r2 viszont egyből felismerte, az AVRSTUDIO továbbra sem látja. A kapott CD-ről stk500 drivert feltölteni nem enged, illetve a WIN7 szerint a legújabb verzió működik a fenti nevekkel, stk500-ról szó sincs. Megpróbáltam drivert letölteni a kapott szöveges leírás szerint a „809” alól, de a válasz; „Ez a modul ki van kapcsolva”.
Tényleg ilyen hülye vagyok, vagy ennek így kell lennie????

Segítségeteket köszönve derűs estét kíván

Tambi

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: Robert » 2015. május 5. kedd, 21:50

AVR-Studioban a COM portszáma a ST5K00-nak 1...8 közt kell lennie.

tambi
Újonc
Újonc
Hozzászólások: 9
Csatlakozott: 2015. május 5. kedd, 19:55

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: tambi » 2015. május 6. szerda, 4:28

Jó reggel Robert!

"AVR-Studioban a COM portszáma a ST5K00-nak 1...8 közt kell lennie."

Ha ez nekem szól, akkor: PC-n COM4, laptopon az internet stick miatt COM8, a jelenség, az stk500 driver-talanság mindkettőnél ugyanaz.

tambi
Újonc
Újonc
Hozzászólások: 9
Csatlakozott: 2015. május 5. kedd, 19:55

Re: Arduino Uno R3 USB-n nem jön fel + tavir STK500 v12 (OSX

HozzászólásSzerző: tambi » 2015. május 6. szerda, 4:50

AVRSTUDIO4.19

Jól van ez így barátaim?

Loaded plugin STK500
gcc plug-in: No AVR Toolchain installation found. The AVR GCC plug-in can still be used if you set up your own build tools.
gcc plug-in: No AVR Toolchain installation found. The AVR GCC plug-in can still be used if you set up your own build tools.
Loaded plugin AVR GCC
Loaded partfile: C:\Program Files (x86)\Atmel\AVR Tools\PartDescriptionFiles\ATmega48


Vissza: “Kizártam magam a chipből...”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 2 vendég