Kínai mega 2560, auto-reset probléma

Ha a chip nem reagál a programozóra...
Avatar
csabeszq
Bitfaragó
Hozzászólások: 670
Csatlakozott: 2012. szeptember 5. szerda, 6:00

Kínai mega 2560, auto-reset probléma

HozzászólásSzerző: csabeszq » 2016. január 27. szerda, 8:32

Megvettem a legolcsóbb kínai Atmega2560 boardot, a probléma, hogy nincs automatikus reset feltöltésnél. Kézzel kell nyomkorászni.

Az Auto RESET a képen látható. Van egy ellenállás, ami felhúzza a RESET-et és 2 kapacitás, az egyik a földre, a másik a DTR-re.
Nem is működik az auto-reset. Úgy tudom, hogy nem kellene elvileg a RESET-hez kapacitás a földre.

Mi a véleményetek?
Nincs meg a kellő jogosultságod a hozzászóláshoz csatolt állományok megtekintéséhez.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Kínai mega 2560, auto-reset probléma

HozzászólásSzerző: Robert » 2016. január 27. szerda, 9:00

A DTR nem megy ki.
Illetve van hogy elcseszik az itteni kondit: 100nF helyett 10nF kerül be.
Olyanom is volt (az Nano esetén), hogy a Resetre a felhúzóellenállás nem 10k volt, hanem 100 ohm :) Persze a kondin át nem kapott reset jelet :P

Ellenálláscsere és megjavult...


Ha van oscilloszkóp, - mérj rá...
Ha nincs: a hangrögzítő meleg ere legyen a reset lábon. És simán digitalizáld be a hangot :).

Avatar
csabeszq
Bitfaragó
Hozzászólások: 670
Csatlakozott: 2012. szeptember 5. szerda, 6:00

Re: Kínai mega 2560, auto-reset probléma

HozzászólásSzerző: csabeszq » 2016. január 27. szerda, 9:41

Annyit próbáltam egyelőre ki, hogy párhuzamosan kötöttem vele 100 nF-t. Úgy ment.

Avatar
csabeszq
Bitfaragó
Hozzászólások: 670
Csatlakozott: 2012. szeptember 5. szerda, 6:00

Re: Kínai mega 2560, auto-reset probléma

HozzászólásSzerző: csabeszq » 2016. január 28. csütörtök, 8:35

Még egy kérdésem lenne.

A 22-es PIN nem megy. Kellene neki?

Sehogy nem megy.
DDRA = 1;
PINA =1

nek forgatni kellene, de nem teszi. Ha ugyanezt a 23-assal csinálom, akkor megy. Kellene neki mennie?

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Kínai mega 2560, auto-reset probléma

HozzászólásSzerző: Robert » 2016. január 28. csütörtök, 19:34

A22: sima I/O-ként mennie kellene.... Nyákszakadás?

Avatar
csabeszq
Bitfaragó
Hozzászólások: 670
Csatlakozott: 2012. szeptember 5. szerda, 6:00

Re: Kínai mega 2560, auto-reset probléma

HozzászólásSzerző: csabeszq » 2016. január 29. péntek, 7:15

Nem, IC hiba lesz. Újraküldetem.


Vissza: “Kizártam magam a chipből...”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 2 vendég