ATMega8

Ha a chip nem reagál a programozóra...
Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2010. október 17. vasárnap, 16:29

Ja, avr-doper? Akkor annak van elvileg 0,7...1,5 MHz-s kimenete.
Amúgy a dopert avrstudioval probald meg használni.

Amúgy a DOPER-ben is lehet a hiba! Nem stabil, és csak szívatós!

LPT port nincs? LowCost STK200 javasolt (5 szál drót :))

Avatar
augre1
Újonc
Újonc
Hozzászólások: 9
Csatlakozott: 2010. október 17. vasárnap, 6:00

HozzászólásSzerző: augre1 » 2010. október 17. vasárnap, 16:31

lehet a dopert avrstudioval használni?
ugy tudtam, h. nem. és még nemis sikerült.
hogyan lehet?

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2010. október 17. vasárnap, 17:24

Ha STK500, akkor lehet....
Bascommal még kevesebb az esélyed!

Vagy ami tuti támogatja - de parancssoros: AVRDuDe

Avatar
DOGMAN
Chipgyilok
Hozzászólások: 293
Csatlakozott: 2006. augusztus 27. vasárnap, 6:00
Tartózkodási hely: Balatonboglár

HozzászólásSzerző: DOGMAN » 2010. november 21. vasárnap, 21:03

Helló!

A TQFP32-es tokozású Atmega8-nál mindegyik VCC és GND lábat be kell kötni?
(VCC 4 és 6 láb a GND 3 és 5 láb)

És az AVCC, AREF, AGND lehet szabadon? (nem használnám ADC-t)


Nem bánnám ha nem mert nem szeretnék még ezért plusz 4 kézi "furatgalvánnal" szenvedni... :)

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2010. november 21. vasárnap, 22:24

Mindet!

Vcc, Avcc a tapfeszre illetve gnd, agnd GNDre!
ARef elvileg maradhat, de ne lebegjen. Kösd vccre.

Avatar
DOGMAN
Chipgyilok
Hozzászólások: 293
Csatlakozott: 2006. augusztus 27. vasárnap, 6:00
Tartózkodási hely: Balatonboglár

HozzászólásSzerző: DOGMAN » 2010. november 21. vasárnap, 22:43

Uhh, ez nem jó hír.

Ez lesz az első SMD panelem, és atom kicsire kell csinálnom...
Kétoldalas lesz mindkét felén smd cuccok, és igy is 3x3 cm-en már 16 átmenő furat van. Pedig már 4-szer teljesen átterveztem :D

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2010. november 21. vasárnap, 22:46

SMD szépségei....
Gyártásba kell küldeni és furatgalvánosítani.... :)

Avatar
szepnorbee
Bitmanipulátor
Hozzászólások: 122
Csatlakozott: 2009. augusztus 31. hétfő, 6:00

HozzászólásSzerző: szepnorbee » 2011. február 18. péntek, 19:26

Üdv! Van vagy 3 mega8-am amit vissza kéne hozni az életbe. (hibás órajelbeáll..) Valaki nem csinálná meg nekem ha elpostáznám neki? Nem sürgős, csak gondoltam rákérdezek. Köszi

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2011. február 18. péntek, 20:25

Külső orajelet adsz a Xtal1 lábára.
Ilyen órajel:

do
toggle kiemeneti lab
loop

Ha a chip 1 MHzrol jar, akkor 250 kHz jon ki:).

Avatar
szepnorbee
Bitmanipulátor
Hozzászólások: 122
Csatlakozott: 2009. augusztus 31. hétfő, 6:00

HozzászólásSzerző: szepnorbee » 2011. február 18. péntek, 20:34

Próbáltam :S Megépítettem a HE-n közölt segédórajel generátort, de az sem segített. Az a baj nincs nagyfesz programozóm, állítólag az segítene. Igaz ez? Nameg kering a neten egy fusebit resetter is, csakhát hobbista révén nincs most pénzem megbenni az abba való uc-t :S

Avatar
szegoj
SzínkódFestő
Hozzászólások: 92
Csatlakozott: 2010. február 4. csütörtök, 7:00
Tartózkodási hely: Budapest

HozzászólásSzerző: szegoj » 2011. február 19. szombat, 10:21

A barátom megépítette az alábbi AVR doktort. Már több "halottat" feltámasztott vele, köztük az általam elrontott M32-t is.

http://diy.elektroda.eu/atmega-fusebit-doctor-hvpp/

Avatar
cicero
Újonc
Újonc
Hozzászólások: 6
Csatlakozott: 2010. augusztus 28. szombat, 6:00

HozzászólásSzerző: cicero » 2011. május 7. szombat, 22:01

szegoj írta:A barátom megépítette az alábbi AVR doktort. Már több "halottat" feltámasztott vele, köztük az általam elrontott M32-t is.

http://diy.elektroda.eu/atmega-fusebit-doctor-hvpp/


Szia!

Én is építettem egy Fuse bits doctort, de sajnos nem működik tökéletesen.
Össze tudnál hozni a barátoddal egy kis eszmecserére, hogy segítséget kaphassak tőle,

Előre is köszönöm.

Róbert

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2011. május 8. vasárnap, 8:27

Mi a hiba? Mi történik benne/vele?

Avatar
cicero
Újonc
Újonc
Hozzászólások: 6
Csatlakozott: 2010. augusztus 28. szombat, 6:00

HozzászólásSzerző: cicero » 2011. május 8. vasárnap, 13:03

Robert írta:Mi a hiba? Mi történik benne/vele?


Szia!

Ma délelőttig nem tudtam vele megjavítani semmit a 2.10 firmvare-vel és ATmega88P processzorral használva. csak a piros LED villogott, és a Hyperterminálban Automata üzemmódban azt láttam, hogy nem tudja a rontott fuse biteket átírni. Kézi üzemmódba nem lehet vele belépni.

Átírtuk a firmvare-t 2.11-re az ATmega88P-ben és PC kapcsolat nélkül megjavított 3 db ATmega8-at és egy ATmega88P-t.Legalábbis a zöld LED világított, és ISP üzemmódban felismerte a CidevisionAVR és az AVRStudió4 is. Amikor akarok írni a flash területre, pl. egy AVR-Doper hex-ét, hibázik. Már a törléskor sem tud minden byte-ot kitörölni.
PC kapcsolatttal RS232-őn keresztül továbbra is csak automatában dolgozik, kézi üzemmódba nem tudom beléptetni.

Ami igazán zavar, hogy szerettem volna ATIÖTEZER AVR-Doper-ét megcsinálni a Hobbielektronikán leközölt cikk alapján, és nem sikerül a hex-et beleégetnem.
Aztán nem igazán értem, miért nem képes belépni kézi üzembe az RS232-őn keresztül???

Dióhéjban ennyi...:-)))

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9993
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2011. május 8. vasárnap, 13:08

AVR-Doper -ujabb szívás!

A programozási hiba: tipp: nincs stabol 12V-od....


Vissza: “Kizártam magam a chipből...”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég