Arduino telepítési problémák

Processing/Wiring (illetve C) nyelvű programozási fogások, tippek. (AVR-Duino, Arduino, EthDuino, Diecimila, Severino, Nano, LilyPad)
Gorrodin
Biztosítékgyilkos
Hozzászólások: 70
Csatlakozott: 2014. július 10. csütörtök, 19:54

Re: Arduino telepítési problémák

HozzászólásSzerző: Gorrodin » 2016. július 5. kedd, 17:05

Van valahol egy leírás arról, hogyan lehet azt megoldani, hogy az IDE megtalálja a hiányzó fájlokat?
Ubuntu alatt használom, és hiába másolom be akár a /usr/share/arduino/libraries könyvtárba, akár a saját mappám /sketchbook könyvtárába, nem találja az fordító a szükséges fájlt.
Az IDE-ben ott a könyvtár, ott vannak az examples könyvtárak, de hiába töltöm be a programot, nem találja az includolt fájlt. Akkor sem, ha a program mellé teszem.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9737
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2016. július 5. kedd, 18:58

Arduino 1.6.4 óta a használd a library managert.
Ja és a library felmásolása nem elég! Arduino induláskor olvassa csak a telepített librarykat, futás közben nem indexeli újra!

Gorrodin
Biztosítékgyilkos
Hozzászólások: 70
Csatlakozott: 2014. július 10. csütörtök, 19:54

Re: Arduino telepítési problémák

HozzászólásSzerző: Gorrodin » 2016. július 5. kedd, 20:23

Arduino 1:1.0.5+dfsg2-2
Az aktuális verzió.
Nincs library manager. Tudtommal.
Egyébként bemásolás után újraindítottam, mégsem látja. Egy példa, hogy néz ki:

/valami_projekt_könyvtár
valami.h
valami.cpp
/examples
examples.ino

és nem találja a valami.h-t

Gorrodin
Biztosítékgyilkos
Hozzászólások: 70
Csatlakozott: 2014. július 10. csütörtök, 19:54

Re: Arduino telepítési problémák

HozzászólásSzerző: Gorrodin » 2016. július 5. kedd, 20:36

Hol találom az alap, a core könyvtárait?

bowman
Újonc
Újonc
Hozzászólások: 12
Csatlakozott: 2016. június 4. szombat, 21:46

Re: Arduino telepítési problémák

HozzászólásSzerző: bowman » 2016. július 6. szerda, 19:42

Ha Windows 64 akkor c:\Program Files (x86)\Arduino\lib\arduino-core.jar

Gorrodin
Biztosítékgyilkos
Hozzászólások: 70
Csatlakozott: 2014. július 10. csütörtök, 19:54

Re: Arduino telepítési problémák

HozzászólásSzerző: Gorrodin » 2016. július 7. csütörtök, 19:15

Ne csak az utolsót olvasd.
Kubuntu

atilla
DrótVégénSzéndarab
Hozzászólások: 25
Csatlakozott: 2016. május 10. kedd, 18:35

Re: Arduino telepítési problémák

HozzászólásSzerző: atilla » 2016. július 9. szombat, 19:23

Én is Linux alatt használom ugyanezt a verziót, és működik a dolog.
Sketch>Függvény importálása?

Jankó
Újonc
Újonc
Hozzászólások: 3
Csatlakozott: 2017. január 7. szombat, 13:12

Re: Arduino telepítési problémák

HozzászólásSzerző: Jankó » 2017. január 7. szombat, 13:25

Sziasztok!

Van egy kis problémám, amiben aa segítségeteket szeretném kérni!
Most jött meg egy Arduno Mega 2560 UNO (CH340) board-om és valamiért nem tudok rá feltölteni.
A következő hibaüzenet jelenik meg:

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
Egy hiba lépett fel a vázlat feltöltése közben


Ez előtt csak UNO-t használtam és az tökéletesen működött, de valaiért a MEGA nem.
Arduino 1.8.0-t használok(de már próbáltam korábbi verzióval is), driver elvileg ugyanaz kell hozzá (ch340). Az arduino 1.8, Eszközökön belül az alaplap + port is helyesen van kiválasztva.
Már több USB bemenetet is használtam hátha az megoldja(külföldi forumon olvastam, hogy valakinél ez bejött), de nálam nem oldotta meg a problémát.

Előre is köszönöm a segítségeteket!

vargham
Tranzisztorgyógyász
Hozzászólások: 151
Csatlakozott: 2014. január 8. szerda, 8:32
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: vargham » 2017. január 7. szombat, 13:53


Jankó
Újonc
Újonc
Hozzászólások: 3
Csatlakozott: 2017. január 7. szombat, 13:12

Re: Arduino telepítési problémák

HozzászólásSzerző: Jankó » 2017. január 7. szombat, 15:37

Köszönöm szépen a gyors választ! Jövő hét elején ki is tudom próbálni!

vargham
Tranzisztorgyógyász
Hozzászólások: 151
Csatlakozott: 2014. január 8. szerda, 8:32
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: vargham » 2017. január 7. szombat, 16:02

Lehet számtalan más oka is, de elsőre ez tűnik a legvalószínűbbnek.

További lehetőségek:
-Cél MCU nem kap tápot.
-Halott az USB illesztő soros része.
-Zárlatos vagy szakadt a panelen az Rx/Tx/reset.

Jankó
Újonc
Újonc
Hozzászólások: 3
Csatlakozott: 2017. január 7. szombat, 13:12

Re: Arduino telepítési problémák

HozzászólásSzerző: Jankó » 2017. január 9. hétfő, 9:08

Ahha, de azért megpróbálom, amit legelőször javasoltál.

Köszi!

adam623
Újonc
Újonc
Hozzászólások: 4
Csatlakozott: 2017. május 18. csütörtök, 10:04
Tartózkodási hely: Sopron

Re: Arduino telepítési problémák

HozzászólásSzerző: adam623 » 2017. május 18. csütörtök, 10:10

D1 minivel küzdök, egyszerűbb programok szépen felmennek a lapra, a Blynk is működik, de az oled kijelzővel nem boldogulok.. Ezt a hibát írja ki:

C:\Users\Kitti\AppData\Local\Temp\arduino_build_464110/arduino.ar(core_esp8266_main.cpp.o):(.text._ZL12loop_wrapperv+0x4): undefined reference to `setup'

C:\Users\Kitti\AppData\Local\Temp\arduino_build_464110/arduino.ar(core_esp8266_main.cpp.o):(.text._ZL12loop_wrapperv+0x8): undefined reference to `loop'

C:\Users\Kitti\AppData\Local\Temp\arduino_build_464110/arduino.ar(core_esp8266_main.cpp.o): In function `loop_wrapper':

C:\Users\Kitti\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.3.0\cores\esp8266/core_esp8266_main.cpp:110: undefined reference to `setup'

C:\Users\Kitti\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.3.0\cores\esp8266/core_esp8266_main.cpp:110: undefined reference to `loop'

collect2.exe: error: ld returned 1 exit status

exit status 1
Hiba a(z) WeMos D1 R2 & mini alaplapra fordításra.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9737
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2017. május 18. csütörtök, 19:03

Melyik OLED?
- 0.66 (D1 méretű panellapon),
- 0.96" I2C,
- 0.96" SPI,
- 1.3" SPI,
- 1.3" I2C.

És melyik videochipkészketes? A 0.96 és a 1.3"-ból eddig 2 félével is talkálkoztam... Az 1.3/0.96" OLED-ből az ellenállások konfigurálják a protokollt! Melyik library-t használod?
http://www.tavir.hu - a gazda :)

adam623
Újonc
Újonc
Hozzászólások: 4
Csatlakozott: 2017. május 18. csütörtök, 10:04
Tartózkodási hely: Sopron

Re: Arduino telepítési problémák

HozzászólásSzerző: adam623 » 2017. május 18. csütörtök, 20:59

Köszönöm hogy válaszra méltattál :)
Oled: 64x48, 0,66"
Driver IC: SSD1306, I2C (D1 méretű panelon)
Próbált Libri: D1_mini_Examples-master


Vissza: “Arduino / C-nyelvű programozás (AVR-Duino, EthDuino, Arduino, Diecimila)”

Ki van itt

Jelenlévő fórumozók: Google [Bot] valamint 1 vendég