Arduino telepítési problémák

Processing/Wiring (illetve C) nyelvű programozási fogások, tippek. (AVR-Duino, Arduino, EthDuino, Diecimila, Severino, Nano, LilyPad)
Avatar
Robert
Elektronbűvölő
Hozzászólások: 9529
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2015. március 17. kedd, 7:58

A cmd ablakban lefuttatás után a előbukkanó, megjelenő ablkakban halványszürkével látszódnia kellene az UNO eszköznek a COM&LPT alatt. ha nincsen:
- nem is volt települve
- már le lett törölve

Illetve a egyéb eszközök / nem azonosított esetén is megjelenhet.

DeathKnell87
Újonc
Újonc
Hozzászólások: 5
Csatlakozott: 2015. március 8. vasárnap, 8:15

Re: Arduino telepítési problémák

HozzászólásSzerző: DeathKnell87 » 2015. március 17. kedd, 8:15

Lefutattam a parancsot majd a másikat de com és lpt-k közt nem látom az unot pedig csatlakoztatva van csak egy komunikációs port van COM1 ami valószínüleg az alaplapomon lévő com port lehet amikor még felismerte az UNO-t akkor a COM4-en ismerte fel.

vargham
SzínkódFestő
Hozzászólások: 80
Csatlakozott: 2014. január 8. szerda, 8:32
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: vargham » 2015. március 22. vasárnap, 14:04

DeathKnell87 írta:Lefutattam a parancsot majd a másikat de com és lpt-k közt nem látom az unot pedig csatlakoztatva van csak egy komunikációs port van COM1 ami valószínüleg az alaplapomon lévő com port lehet amikor még felismerte az UNO-t akkor a COM4-en ismerte fel.


A parancssort (cmd.exe) futtatás rendszergazdaként indítottad el? Csak akkor működik a rejtett eszközök megjelenítése.

Avatar
albinolynx
Tranzisztorgyógyász
Hozzászólások: 161
Csatlakozott: 2007. október 28. vasárnap, 6:00
Tartózkodási hely: Veszprem
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: albinolynx » 2015. április 15. szerda, 18:21

Sziasztok!

Megérkezett egy UNO R3 klónom. Elméletileg sikerült telepíteni. Eszközkezelőben: usb-serial CH340 (COM4)
eszközként megjelenik. 1.0.5-ös arduino programban -> soros monitor -> blink -> X1 jelölésű led felvillan.
Elméletileg ez így rendben van?

GRBL léptetővezérlőt szeretném majd beüzemelni. Erről majd a megfelelő topikban írok.
Ha lehetséges .HEX fájlt szeretnék flashelni, nem pedig forráskódból fordítani. Majd elválik...

Avatar
albinolynx
Tranzisztorgyógyász
Hozzászólások: 161
Csatlakozott: 2007. október 28. vasárnap, 6:00
Tartózkodási hely: Veszprem
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: albinolynx » 2015. április 15. szerda, 18:57

albinolynx írta:...


Elfelejtettem írni, hogy a nano v.3.0. is megérkezett. Ahhoz rendesen FDTI driver kellett (1.0.5) driver
könyvtárból szépen települt. Soros monitor -> blink -> Rx led felvillan. A cél szintén a GRBL.

Avatar
csegebiga
Pákabűvész
Hozzászólások: 224
Csatlakozott: 2015. március 27. péntek, 21:27

Re: Arduino telepítési problémák

HozzászólásSzerző: csegebiga » 2015. július 16. csütörtök, 10:51

üdv!
segítség kéne.
elvesztettem a fonalat.
hogy is van ez?
az arduino.cc letöltés linkje most az ARDUINO 1.6.5 verziót kínálja letöltésre
az arduino.org letöltés linkje pedig az Arduino 1.7.6 verziónál jár link

régebben Róbert mindig azt mondta, hogy az 1.5XXX verziók még teszt vagy próba kiadások. és tessünk az 1.1.X kiadásokat használni.
jó, de most akkor mi a helyzet?
mik a használható buildek, és melyikek kerülendők messzire?
vannak-e (in)kompatibilitási problémák, mennyire átjárhatók a klf verziók?

más fórumokon láttam, hogy a fórum gazdája nyitott egy (mindig elől lévő) topicot, aminek az első bejegyzésében mindig az aktuális verzió elérhetőségei szerepeltek. mögötte pedig a tagok kitárgyalták tapasztalataikat, ötleteiket.
nagy hüleség lenne itt is egy iljen topic javaslata?
thx4all!
(c)csege

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9529
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2015. július 16. csütörtök, 16:36

Épp cikket írok:
Arduino.cc - jogu és szellemi háttér valamint a licensztulajdonos.
arduino.org - aki a HW-t gyártotta és a első csoport _nélkül_ védjegyet jegyeztetett be USA és Italy területen. Most pereskedés megy.

Arduino.cc a hivatalos hely.
arduino.org oldalágnak tekintendő...


Pontosítok, 1.1xet sose mondtam :) :
1.0.x ág - Arduino AVR ága
1.5.x - ARM, AVR BETA teszt ág. Nem javasolt használni
1.6.x - összevont ág (1.0.6 után ez jött) és az 1.5.x szolgáltatásokkal, bugokkal.

A letöltések/verziókban igyekszem követni a változásokat.
Arduino.org - oldalág jelenleg.

A kompatibilitás csak részleges!
Arduino-00xx ;
Arduino-1.0...1.0.6
Arduino-1.5.0...1.5.9 BETA
Arduino-1.6.0...1.6.5 (elvileg végleges, összevont)


Verziók:
viewforum.php?f=5

kukuri
Bitmanipulátor
Hozzászólások: 124
Csatlakozott: 2014. január 20. hétfő, 12:50

Re: Arduino telepítési problémák

HozzászólásSzerző: kukuri » 2015. július 19. vasárnap, 20:00

Üdvözletem.

A következőképpen jártam. Van egy Mega 2560 klónom. Szépen működik is egy ideje. Jópár felprogramozás után egyszercsak elkezdett mibát adni a kód feltöltése végén.
Fájlokat hiányolt és még sokmindent. Újra próbálom a feltöltést és gond nélkül fel is rakta a kódot. Ezt párszor megjátszotta. Egyszercsak már hiába indítottam rá a feltöltést, nem járt sikerrel. Pc újraindít, USB-ről lehúz visszadug. Újraindítás után megint tudtam írni. Viszont egyre többször problémázik. Mégnem már nem is akarja semmilyen formában felírni a kódot.
A 100.000 programozási ciklust még biztos nem értem el.
Lehetséges hogy a klónokat csak 1-2.000- szer lehet újraprogramozni és utána kuka?
UNO val is jártam már így.
Win 7 64 bites rendszert használok ha ez jelent valamit. 1.6.3 progival.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9529
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2015. július 19. vasárnap, 20:20

Itt más a gond:
- kontakthiba
- driver frissülés/fejreállás
- ólommentes forrasztás hidegtörése

Amúgy ár-érték arányos a holmi ?:)

kukuri
Bitmanipulátor
Hozzászólások: 124
Csatlakozott: 2014. január 20. hétfő, 12:50

Re: Arduino telepítési problémák

HozzászólásSzerző: kukuri » 2015. július 19. vasárnap, 20:38

Érdemes volna újratelepíteni a bootloadert?
Vagy hagyjam az egészet és keressek másik panelt?
Van erre tapasztalat hogy ha eredeti olasz panelt veszek akkor pl 10X kevesebb a gondom vele?

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9529
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2015. július 19. vasárnap, 20:59

A bootloadernek mi köze a kontakthoz?
De rengeteg hiba lehet a rendszerben (ebből 3-at adtam meg, van olyan 40 feletti lehetőség...)


A minőségbiztosításban van kemény eltérés.

kukuri
Bitmanipulátor
Hozzászólások: 124
Csatlakozott: 2014. január 20. hétfő, 12:50

Re: Arduino telepítési problémák

HozzászólásSzerző: kukuri » 2015. július 19. vasárnap, 21:24

Ennek a hibának a kiderítését akkor passzolom.
Melyik Mega panelt javaslod hogy ne járjak vele így?
Eddig azt gondoltam, hogy a klón jó gyakorolni. Már kezdem megváltoztatni a véleményemet.
Már van 4-5 ethernet shieldem is amik így jártak. Egyszercsak elkezdtek melegedni és elhalványodtak a ledek.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9529
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2015. július 20. hétfő, 3:14

Ott akkor más gond lesz. Ennyire nem hullanak a panelek...
- dobálva, ütve, rakosgatva vannak (állandó rázkódás, hajlítás)
- statikusan töltődés van (szőnyeg, földelt páka, asztallap, szék, egyéb eszközök nélkül)

Ha ezek valamelyike áll fenn, akkor bármelyik eszköz ennyire hullani fog....

kukuri
Bitmanipulátor
Hozzászólások: 124
Csatlakozott: 2014. január 20. hétfő, 12:50

Re: Arduino telepítési problémák

HozzászólásSzerző: kukuri » 2015. július 20. hétfő, 7:16

A panelek asztalon vagy földön vannak. Ahol van éppen hely. Mivel tesztelgetem próbálgatom mit tudnak.
Ezek szerint kell egy panel ahova felrögzíthetem a lapokat és dugdoshatom a kábeleket. Amúgy is kell ilyen mert csak baj van vele hogy nem fixen rögzítettek a panelek. Csúszkálnak minden irányba.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9529
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino telepítési problémák

HozzászólásSzerző: Robert » 2015. július 20. hétfő, 19:32

A föld alatt szőnyeg értendő? -> Statikus töltődés.
Mondjuk én ilyet használok:

http://shop.tavir.hu/images/modul-plate-3.jpg
Ez UNO méret + 400-as breadboard.
Csak most már fém illetve műanyag távtartó is van. A műanyagot jobban szeretem - tuti nincs rövidzár :)

Pl. itt:
http://shop.tavir.hu/product_info.php/a ... phoz-p-322

De van ugyanennyiért ebay is.... (3 EUR környékén)


Vissza: “Arduino / C-nyelvű programozás (AVR-Duino, EthDuino, Arduino, Diecimila)”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég