Akvárium tápadagoló - motor zaj

Processing/Wiring (illetve C) nyelvű programozási fogások, tippek. (AVR-Duino, Arduino, EthDuino, Diecimila, Severino, Nano, LilyPad)
mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 18. szombat, 16:11

Sziasztok!

Nem kimondottan programozás, de azért remélem jó helyre írom. Akvárium vezérlést építenék egy Arduino Nanoval, de a motoroknál teljesen elakadtam.

A problémám a következő: Egy tápadagoló pumpa 12V-os motorja által keltett zaj miatt valamilyen hiba keletkezik az I2C kommunikációban (óra modul) és emiatt végtelen ciklusba kerül az Arduino. Hogyan tudnám kiküszöbölni a motor zaját?

Konfig:
12V hajtja meg egy IRFZ44N mosfeten keresztül a motort, 1N5819 Schottky diódával, 10k lehúzó ellenállással. A vezérlés szépen működik is. Az időt egy DS1307-es tinyRTC modultól kapom, ami I2C buszon kommunikál (Wire.h). (Kb mint itt: http://bildr.org/blog/wp-content/upload ... -motor.png)

Amit eddig próbáltam:
- Ha kiveszem (vagy nem használom) az RTC-t, akkor minden szuper stabil. Szóval a motor elég biztosan az óra lekérdezésébe zavar bele.
- akár 9V-os, akár 12V-os LED tápról meghajtva, L7805CV fesz szabályzóval csináltam 5V-ot az arduinonak. Csak Ledeket vezérelve tök jó, motorral halál. Mindegy milyen kondikat tettem a lábaira.
- 12V-os táp -> LM2596 szabályozható DC-DC -> 5V dettó ugyanaz
- 12V-os táp csak a motornak, USB 5V az arduinóhoz, szóval két teljesen külön tápról meghajtva, csak a földeket összekötve, szintén ugyanúgy jelentkezik a hiba. Ez az a pont ahol már kezdem feladni. Itt elvileg csak a GND és a mosfetet vezérlő 1db pin ami összeköti a két kört, mégis valahogy átmegy a zaj.

Próbáltam a motorral párhuzamosan tenni 1uF, 10uF, 470uF-os kondikat, nem segített.
Próbáltam a DS1307 +5V-ja és a GND közé kisebb-nagyobb kondikat, nem segített.
Próbáltam közvetlen a motorra tenni a diódát és egy 100nF-os kondit, (vagyis 20cm-rel távolabb az arduinotól), de ugyanúgy rossz.
Ha tettem az A4 és A5 lábakra (SDA,SCL) egy-egy 4,7K-s pull-up ellenállást (mivel a belső 20k-s pulluppal úgy tűnik lassú), akkor egész stabil, egy 10uF-os kondival a motoron csak egy-két óra alatt lehet előidézni a hibát, de még mindig nem volt 100%-os.

Eddig motor nélkül csak a led világítást vezérelve kb. 3 héten át teljesen stabilan ment ugyanezekkel a dolgokkal a rendszer.
Szóval tanácstalan vagyok. Lehet, hogy rossz az óra modul? Egyelőre nem tudom másikkal kipróbálni sajnos, de majd le akarom cserélni DS3231-re, mert ez nagyon pontatlan. Elvileg relékkel is meg lehetne oldani, mert nem kell PWM ezekhez, de még nem adtam fel, hogy egy ennyire triviális vezérlést ne tudjak stabilan megcsinálni.

Bármilyen tippet vagy javaslatot előre is hálásan köszönök!

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 18. szombat, 16:18

Még annyival kiegészíteném, hogy a teszt kódban szándékosan extrém gyakran, gyakorlatilag szünet nélkül kérdezgetem az órát, hogy a hibát könnyen tudjam reprodukálni. Elvileg szoftveresen megoldható lenne úgy is, hogy csak óránként vagy naponta egyszer kérdezem le az időt, de ezzel csak a tüneteket fedném le, az esély ugyanúgy megmaradna a hibára, ami egy tápadagolás esetén katasztrofális következménnyel járna.
Szeretném valahogy a hiba okát kezelni, vagyis a motor zaját eltüntetni, már ha ez egyáltalán lehetséges.

Avatar
csegebiga
Chipgyilok
Hozzászólások: 283
Csatlakozott: 2015. március 27. péntek, 21:27

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: csegebiga » 2017. november 18. szombat, 21:58

Én még odatennék a vezérlő láb és a gnd közé egy 5.1Vos Zenert, hogy az esetleges feszültség tüskéket /negatív impulzusokat lenyelje.
Vagy:
Optokapuval próbáltad már a vezérlést izolálni a motor tól/fettől? Akkor még a gnd sem lesz közös a két áramkör között. Az Arduino felől akkor egy ellenállás és egy led látszik.
A motornál ugyanúgy érdemes egy diódás/Zeneres védelmet berakni, mert az induktivitások elég nagyokat tudnak visszarugni (Lenz törvény, ha jól emlékszem) ez akár a fetet is kinyírhatja

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 19. vasárnap, 10:26

Szia Csege, köszi szépen a választ!

Közben kipróbáltam teljesen szétválasztva az áramköröket, egy (elvileg optocsatolt) relémodullal, teljesen külön tápokkal, és meglepő módon így is jelentkezett a baj. Ez után már csak az maradt, hogy alufóliába csavartam a motort, és most épp így megy. Nem akarom elkiabálni, de lassan fél órája már megy és még mindig jó. Szóval úgy tűnik, hogy az óra nagyon érzékeny az elektromágneses (?) zavarokra, és nem is az elektromos tüskék okozták a bajt. Kíváncsi vagyok mi történik, ha visszakötöm a mosfetre az egészet így leárnyékolva...

Avatar
csegebiga
Chipgyilok
Hozzászólások: 283
Csatlakozott: 2015. március 27. péntek, 21:27

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: csegebiga » 2017. november 19. vasárnap, 13:22

Ellenpróbát javaslok:
tedd az áramköröd mellé a motorodat, és manuálisan kapcsolgasd ki-be.
így megbolondítja-e a RTC modult?
ha igen, akkor jellemzően melyik? a motor indulása, vagy a leállása?
ha tényleg EM zavar csinálja a galibát, akkor vagy az áramkört, vagy a motort be kell csomagolni Faraday kalitkájába,
vagy egy konzervdobozba :)
ezután megszűnik-e a jelenség?

Hány ampert kapcsolsz nagságrendileg?
Van-e hosszabb vezetéked a rendszerben, ami antennaként összeszedheti a motor zaját?

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 19. vasárnap, 15:09

Nagyon jó ötlet! Árnyékolás nélkül, kézzel kapcsolgatva is megbolondítja. Árnyékolva nem, vagy nem volt elég türelmem hosszasan tesztelni. :)

Most próbálom a motort becsomagolva, de mosfettel és egy 470uF-os kondival, hogy mit csinál. Az óra modul táp lábaira is tettem egy 100nF-ot, plusz visszatettem a felhúzó ellenállásokat a I2C lábakra. Egyelőre működik.
Azt hiszem lassan sikerül kimeríteni minden lehetőséget, szóval ez lesz az utolsó variáció. Utána marad a szoftveres tüneti kezelés.

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 19. vasárnap, 18:48

Nos az egyetlen megoldás, amivel stabilan működik az az, ha nem használom az I2C buszt amíg jár a motor. Illetve két külön táppal, relével és motor árnyékolással is jónak tűnt, de közös tápról szeretném futtatni, szóval ez a verzió sajnos nem lesz jó. Minden más esetben előbb-utóbb bezavart a motor az óra lekérdezése közben. Kicsit csalódott vagyok, hogy nem sikerült megoldani, de ha megjön a másik óra modul, akkor kipróbálom azzal is. Nagyon gyanús, hogy csak ez a konkrét modul ami ennyire érzékeny.

A tipppeket mindenesetre nagyon szépen köszönöm!

A motorról egyébként nincs sok infóm, elvileg 12V-os és 80mA-t ír rá, de a valóságban egy 2A-es tápról simán felvett 2,5A-t a 6A-es LED tápról meg 4,5A-t amit nekem nagyon furcsának tűnik, de mondjuk nem értek hozzá. Viszont nem füstöl, nem melegszik, nem kattog, hosszas járatás után sem, szóval remélem rendben van így. Kb 10 másodpercet fog egyébként járni naponta.
Kérdezted még a vezetéket, 10cm-es patch kábelekkel van összedugva az egész, csak a motor van egy 30cm-es kábelen.

atilla
DrótVégénSzéndarab
Hozzászólások: 47
Csatlakozott: 2016. május 10. kedd, 18:35

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: atilla » 2017. november 20. hétfő, 7:09

Mi történne, ha az I2C kommunikáció sebességét jelentősen lelassítanád. Felére, esetleg negyedére?

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 21. kedd, 0:35

atilla írta:Mi történne, ha az I2C kommunikáció sebességét jelentősen lelassítanád. Felére, esetleg negyedére?

Ez is jó ötlet lehet, nem is tudtam, hogy ilyet is lehet csinálni. :)

Viszont ma megérkezett a DS3231-es óra, és azzal kipróbálva egészen stabilan fut a rendszer. Szóval tényleg arról lehetett szó, hogy ez a konkrét DS1307-es óra nagyon érzékeny volt a zajokra. Az mindenesetre biztos, hogy a jövőben oda fogok figyelni, hogy lehetőleg minél kevesebb forgalom menjen a I2c buszon akkor ha közben ilyen zajos eszközök is járnak.

Visszatérve a motorra. Az normális, hogy ilyen sok áramot hajlandó felvenni a motor terhelés nélkül is? Elvileg ez 80 és 500mA között kellene, hogy működjön, de üresen járatva is stabilan 1A-t vesz fel, és ha ráteszem a dózis puma fejet, akkor felmegy 4 - 4,5 A-re (egy 2A-es tápról járatva is).
Elnézést, ha butaságot kérdezek, nem értek ezekhez a dolgokhoz, de nem lenne érdemes levenni valahogy a feszültségét? Vagy akkor pont hogy nagyobb áramot venne fel? Nem igazán úgy méreteztem az áramkört, hogy ilyen áramok menjenek rajta kersztül. :S

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9904
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: Robert » 2017. november 22. szerda, 7:47

Elnézést, ha butaságot kérdezek, nem értek ezekhez a dolgokhoz, de nem lenne érdemes levenni valahogy a feszültségét? Vagy akkor pont hogy nagyobb áramot venne fel? Nem igazán úgy méreteztem az áramkört, hogy ilyen áramok menjenek rajta kersztül. :S


Ajaj. Ohm törvényt nagyon gyorsan elevenítsd fel - elektronika kapcsán hamar gondok lesznek :)


Amúgy ha Kínai a motor, akkor az adatlap tájékoztató érték.... :(
De szerintem nem normális. A tápok 2x túlméterezése sem (2A táp lead 4A-t).
Szerintem a multiméteredben cserélj elemet :)
http://www.tavir.hu - a gazda :)

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 22. szerda, 21:42

Robert írta:Szerintem a multiméteredben cserélj elemet :)


Na ez segített, köszi szépen a tippet! (Pedig a régi elem még 8.6V-ot ad.)

Az új elemmel már csak 600mA-t mutat a mérő a motorokon terhelés nélkül. A pumpa fejjel meg 2,5A-t.
Egyébként a ledes lámpa 6A-es tápjáról fog majd működni, csak itt az asztalon csak egy 2A-es 12V-os van.

Köszi a segítséget. Végre állhatok neki a kódnak! :)

Avatar
csegebiga
Chipgyilok
Hozzászólások: 283
Csatlakozott: 2015. március 27. péntek, 21:27

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: csegebiga » 2017. november 22. szerda, 23:16

Szerintem ott vagy, ahobnan kezdted.
Valamelyik hozzászólásodban írtad már, hogy a 2Amperes tápodról eszik 2.5A-t, a 6Aesről pedig 4.5Á-t.
A 2Á es táp bekorlátoz 2.5Anél, azért 'csak' ennyi a fogyasztása.
Azt nehezen hinném, hogy nem melegszik a motor, ha 4.5A eszik terhelve, mert olyankor 4.5A*12V=54W teljesítményt vesz fel. Ez azért előbb-utóbb megsüti a motor tekercseit.
Miért szorul ennyire az etetőmechanikád?
Egy akvárium etetéséhez tényleg kell 50Watt?

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 23. csütörtök, 0:27

Ez nem etető szervó, hanem a növénytáp folyadék pumpa, ilyesmi:
https://sc01.alicdn.com/kf/HTB1gYSwKXXX ... XFXXXB.jpg
Megmértem a 6A-es tápegységgel is csak 2.5A-t mutatnak a motorok, bár van motoronként is némi eltérés.
Mivel csak pár millilitert kell naponta tolni a tápokból, ezért egy-egy motor 5-10 másodpercig fog futni, szóval nem nagyon aggódok a melegedés miatt.

Amiről viszont még nem volt szó, de nem vagyok teljesen biztos benne, az a nagy Ledes világtás vezetékezése. A lámpa max fényerőn 5.5A-t tud felvenni, de most a vezérlőn csak egy 0.6mm-es tömör rézvezeték viszi a mosfethez a tápot. Ez kb 10 cm vezeték. Amennyire utána tudtam olvasni, ezen akár 9A is biztonságosan használható.
Jól értelmeztem ezt? Vagy tegyen egy nagyobb drótot oda?

vargham
Pákabűvész
Hozzászólások: 227
Csatlakozott: 2014. január 8. szerda, 8:32
Kapcsolat:

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: vargham » 2017. november 23. csütörtök, 7:09

http://www.vistar.hu/katalogus/Kabel.pdf

Amit megadtál, az 0,6 mm2?

mbence
Újonc
Újonc
Hozzászólások: 10
Csatlakozott: 2017. november 18. szombat, 14:45

Re: Akvárium tápadagoló - motor zaj

HozzászólásSzerző: mbence » 2017. november 23. csütörtök, 8:57

Az átmérő 0.6 mm.


Vissza: “Arduino / C-nyelvű programozás (AVR-Duino, EthDuino, Arduino, Diecimila)”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 2 vendég