Meghalt a chip?

Rendszerközeli nyelv(ek) tippjei, alkalmazásai
Avatar
peti634
DrótVégénSzéndarab
Hozzászólások: 37
Csatlakozott: 2009. június 22. hétfő, 6:00
Tartózkodási hely: Nyíregyháza

Meghalt a chip?

HozzászólásSzerző: peti634 » 2009. december 5. szombat, 22:04

Üdv.
Az AVR ATTiny2313-ba van egy egyszerű villogó progi. Rendesen villog, de amikor nem kellene világítania akkor halványan világit. Tönkrementek az IO portok?

Avatar
winnerbt
Chipfüstölő
Hozzászólások: 886
Csatlakozott: 2007. március 25. vasárnap, 6:00
Tartózkodási hely: Kecskemét

HozzászólásSzerző: winnerbt » 2009. december 6. vasárnap, 19:23

Lehet.
De én megnézném a tápot, már hogy normálisat kap-e, nem csak pl. a programozótól kapja. Ilyen még akkor szokott előfordulni, ha a LED pl. a nyers tápfeszen, a stabilizátor előttről kapja a + tápot, ami magasabb lehet, mint az IC tápfesze, akkor a kimeneti 1 szint is elég alacsony ahhoz, hogy világítson a LED. Persze lehet SW gond, vannak olyan megoldások, hogy pl. mindig mindent bekapcsolunk, utánna egy a rutin kikapcsolja, ami nem kell, no ilyenkor a pár usec-es hajtás is látszik a LEDen.
JAni

Avatar
peti634
DrótVégénSzéndarab
Hozzászólások: 37
Csatlakozott: 2009. június 22. hétfő, 6:00
Tartózkodási hely: Nyíregyháza

HozzászólásSzerző: peti634 » 2009. december 6. vasárnap, 21:42

az AVR-t csak a táv hajtja, attól félek hogy előtte elég sok tápot kapott, és nem tudtam rendesen programozni, és kitudja mit kötöttem rossz helyre és nem birták a lábak. A resetet muszáj lekötni? Ha lekötöm, ha nem nincs változás, csak ha a GND-re kötöm, ekkor persze resetel.

Avatar
winnerbt
Chipfüstölő
Hozzászólások: 886
Csatlakozott: 2007. március 25. vasárnap, 6:00
Tartózkodási hely: Kecskemét

HozzászólásSzerző: winnerbt » 2009. december 7. hétfő, 9:45

Szerintem cserélj uC-t. A RESET-en van egy belső felhúzó, tehát szabadon hagyhatod, de én inkább csinálok hozzá resetáramkört.


Vissza: “ASM programozás”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég