ESP-01 AT parancsokra nincs válasz

ESP8266, ESP32 chipek és az ESP-xx modulok. Programozási nyelvek, trükkök, hardware tippek.
suketnemet
Újonc
Újonc
Hozzászólások: 13
Csatlakozott: 2020. november 14. szombat, 4:00

ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: suketnemet »

Sziasztok!

Vettem egy ESP-01-es modult. Sajnos a kezdő lépéseknél elakadok, nem érkezik válasz az AT parancsokra. Amit eddig tettem:
- Letöltöttem Boards Managerben az esp8266 (by ESP8266 Community)-t (bár itt még nem volt használva, így ebből a szempontból kb mindegy)
- összekötöttem az esp-01-esem a nano-val az alábbiak szerint:
esp-01 tx -> arduino tx-re
esp-01 ch_pd -> arduino 3.3V-ra
esp-01 vcc -> arduino 3.3V-ra
esp-01 GND -> arduino GND-re
esp-01 rx -> arduino rx-re

Amit tapasztaltam:
Ha Nanora csatlakoztatom az ESP-01-et, akkor az Arduino fejlesztői környezetben a Tools/Port inaktív, nem tudom kiválasztani. Ha Uno-ra kötöm, ezzel nincs gond, ellenben bármilyen AT-s parancsot írok be a Serial monitorba, semmi válasz nem érkezik. 9600-os baud-ot állítottam be előzőleg, mert azt olvastam valahol, hogy azon érdemes próbálkozni.

Több videómegtekintés és netes tutorial után feladtam a harcot. Ha valakinek van ötlete, ilyenkor mi a teendő?

Illetve ha tudna valaki linkelni egy működő tutorial-t, azt megköszönném!
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10140
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: Robert »

Tx/Rx-et cseréld meg. Nano processzor igaz reset-ben van?

Leírás: http://old.tavir.hu/iot-1-at
http://www.tavir.hu - a gazda :)
suketnemet
Újonc
Újonc
Hozzászólások: 13
Csatlakozott: 2020. november 14. szombat, 4:00

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: suketnemet »

"Error opening serial port 'COM7'. (Port busy)" Ezt kapom, ha felcserélem, és TX megy RX-re, RX meg TX-re.

"Nano processzor igaz reset-ben van?" Ha ez a kérdés arra irányul, hogy az Arduino reset pin-je GND-n van-e, kipróbáltam úgyis, hasonló "eredménnyel".

"Board at COM7 is not available".

Eddig ezt a megoldást követtem:
https://www.instructables.com/Getting-S ... 66-ESP-01/
Amihez nagyon hasonlót találtam magyarul is:
http://faragocsaba.hu/esp8266

Betűröl betűre próbálom ugyanazt csinálni, de már a kezdeti szakaszban kudarcra futok.
Valaki mondja már ki, hogy a fenti két linken mi történik! Jó az a leírás, vagy netto baromság? Ha jó, mit tudtam elrontani, hogy nálam mégsem megy?
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10140
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: Robert »

Ha eldobja a sorosportot:
- túlterheted a 3.3V-os részét a Nano-nak!
-> ha nincs külön 3.3V stabIC rajta, akkor a CH340 vagy a FT232RL 3V3 kimenete van a ESP-re kötve.

ESP áramfelvétele: WiFi-kor 150-200mA is lehet (alapesetben ~30mA), míg a CH340 <10mA, FT232RL 50mA leadására alkalmas. Ha ezt túlléped, akkor lekorlátoz.

"Azaz a hiba az Ön készülékében van!"
http://www.tavir.hu - a gazda :)
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10140
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: Robert »

Maradj az UNO-nál.

- A soros sebesség 115200bps illetve 9600bps lehet (firmwarefüggő)
- Tx-Rx bekötés esetén a AVR RESET-ben legyen.
- ESP01-re én csak a Tx/Rx, Vcc/GND-t kötöm be...
http://www.tavir.hu - a gazda :)
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10140
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: Robert »

Ja és a ESP-01 Rx lába NEM 5v toleráns!
http://www.tavir.hu - a gazda :)
suketnemet
Újonc
Újonc
Hozzászólások: 13
Csatlakozott: 2020. november 14. szombat, 4:00

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: suketnemet »

Köszönöm a választ!

Már kezdtem azon gondolkozni, hogy akkor ehhez az ESP-hez mindenképpen kell vegyek egy hardweres ESP programozót is (CH340 vagy a FT232RL).
A leírtak szerint cselekedtem, külön tápot kapott az ESP, működik az AT parancs. (mégegyszer köszönöm a segítséget). 3.3V-os stab ic-m sajnos nem volt kéznél, de volt itthon egy MB102 Breadboard Module Adapter Shield 3.3V/5V. Viszont elég gyenge a specifikációja, nem írja mennyi a max áram amit le tud adni. Átmeneti megoldásnak viszont jó.

A linkekben szereplő példákról kimondható hogy hibás tutorialok?

Róbert! Ha már így külön említed, az Rx-lábat kell külön is védeni?

Illetve a 3.3V-os stab IC az működtethető Arduino 5V-ról? Jó lenne kiküszöbölni, hogy 2 külön tápról kelljen gondoskodni.
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10140
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: Robert »

MB102 az melyik?
Ha ez: https://shop.tavir.hu/termek/shop/ardui ... modul-iii/
Akkor a stabIC puskázható: 0,5...0,7A a kimenete. Bemenete mehet az AVR 5V-ról.

A linkben levő tutorialok inkább: pontosításra szorulnak.

Igen, illik az Rx lábat legalább ellenállásosztóval védeni...
http://www.tavir.hu - a gazda :)
suketnemet
Újonc
Újonc
Hozzászólások: 13
Csatlakozott: 2020. november 14. szombat, 4:00

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: suketnemet »

Ok. Közben utánajártam, ehhez a 3.3V-hoz elég egy 1:2 arányú feszültségosztó.

MB102: Nagyon hasonló, de az enyémen van USB kimeneti csati.

A Tx-el mi a helyzet? Feltételezem, hogy az ESP-01-ból ilyenformán már csak 3.3V mehet Tx-en keresztül az arduino felé. De ha az arduino 5v-ot vár, akkor azzal nem kell külön bíbelődni?
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10140
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: Robert »

Tx: ESP kimenete . AVR bemenete: 1.1V felett H szintnek tekintendő...
Azaz simán kösd össze....


Én nem barkácsolok, ESP-01 programozót használok:
https://shop.tavir.hu/termek/shop/ardui ... -esp-link/
http://www.tavir.hu - a gazda :)
suketnemet
Újonc
Újonc
Hozzászólások: 13
Csatlakozott: 2020. november 14. szombat, 4:00

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: suketnemet »

Hát a végén lehet, hogy nálam is az lesz. Amióta összeeszkábáltam egy feszültségosztót, sehogy sem akarja kiírni a választ. Eskü ugyanazt csináltam, de semmi válasz. Már osztó nélkül sem. Rejtély... Mintha valami különös csillagegyüttállás kellene hozzá... nem mindegy melyik kap először tápot, hogy a reset menet közben lett-e átdugva... már csak ilyenekre tudok gondolni...
suketnemet
Újonc
Újonc
Hozzászólások: 13
Csatlakozott: 2020. november 14. szombat, 4:00

Re: ESP-01 AT parancsokra nincs válasz

Hozzászólás Szerző: suketnemet »

Lehet ezt resetelni valahogyan véletlenül, hogy többet ne reagáljon az AT parancsokra? Egész nap ezt a mérget eszem... már egy kicsit unom az ízét!
Válasz küldése