AVRISP MKII és AVR-Studio 6

Az AVR chipek demoboard-ja, és ennek kínkeserves tapasztalatai...
Avatar
ImTilk
Újonc
Újonc
Hozzászólások: 14
Csatlakozott: 2010. február 6. szombat, 7:00
Tartózkodási hely: Velence

HozzászólásSzerző: ImTilk » 2012. április 16. hétfő, 10:05

Sziasztok!

Egy pozitív tapasztalatot szeretnék megosztani az új atmel studió 6, kontra gyári AvrIspMKII-vel.
A hétvégén feltettem, szeretem kipróbálni az újdonságokat, idáig AVR Studio 5.0-át használtam,az állandóan nyafogott az MKII-re, hogy firmware frissítés kéne, de ha feltettem, akkor működésképtelenné vált a programozóm, vissza kellett raknom a 4-es stúdióban lévő régi drivert...
(Ahogy néztem a neten ez nem csak nálam jött elő)
A másik ami negatívum volt, hogy 125khz-nél nem tudtam feljebb vinni a programozás sebességét,ami különösebben nem zavart annyira, de mondjuk egy mega128-nál már huzamosabb időnek mondható a programozás+ellenőrzés...

Az új stúdióval jött új usb driver is, meg firmware is, felraktam mind a kettőt, tökéletesen működik, és most már 2mhz a programozási sebesség határa, ami azt jelenti nálam, hogy egy mega324-el 97%-os telítettségnél 2-3 mp alatt végez ellenőrzéssel együtt.(Ez 125 khz-nél 18-20mp volt)
No ennyi :) Hátha valakinek hasznos infó volt....

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9910
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2012. április 16. hétfő, 12:24

A 6-os verzió még nem Beta?

Az MKII utángyártott az 4.19 alatt tesztelve: 4 MHz-n égethető a 16 MHz-s kvarcos AVR :).
Fontos!
Ha nagy sebességgel égeted az eszközt, akkor az max. 250 kHz lehet - alapórajel esetén. Ha nagyobb sebességre van szükség, akkor először az AVR órajelet állítsd be, és csak utána programozz nagyobb sebességen!
A hozzászólást 1 alkalommal szerkesztették, utoljára Robert 2012. április 19. csütörtök, 7:23-kor.

Avatar
ImTilk
Újonc
Újonc
Hozzászólások: 14
Csatlakozott: 2010. február 6. szombat, 7:00
Tartózkodási hely: Velence

HozzászólásSzerző: ImTilk » 2012. április 16. hétfő, 12:52

De igen, béta...
Egyenlőre problémát nem látok vele, és túl sok különbséget se az 5-ös verzióhoz képest, (legalábbis AVR vonalon),kivéve amit feljebb említettem (számomra) pozitívumokat...
Az 5-ös stúdióval és a régi firmware-val semmilyen órajelen se tudtam felmenni 125khz fölé stabilan...
Itt 8mHz-es kaviccsal megy a 2mHz...
Köszi a tanácsokat, meg a topiknyitást is, nem akartam egy ilyen egyszerű hozzászólás miatt új topikot nyitni...

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9910
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2012. április 19. csütörtök, 7:22

Az MKII clone eszközökhoz megjelent firmware.
Sikerült a Studio4 mellé a Studio5.1 illetve 6-t feltelepíteni.
Az eredmény: a _teljes_ rendszer újratelepítése (Win7x64). A Jungo driver telepítése illtve frissítése során sikerült elérni azt az állapotot, hogy _semelyik_ AVR-Studio nem látja. A Jujngo driverfrissítés log-jából az látszik, mintha nem tudta volna frissíteni a telepítő...

A korábbi állapot visszaállítása című mutatvány sem segít rajta...
Sőt, ha driverfrissítést kérsz a Jungo-hoz, akkor a netről lehúz egyet, ami újabb, mint az Atmel verziója... (azonban ez sem javított a helyzeten).


A firmwarefrissítés (2012-03-18-i) az AVRStudio 5.0 illetve 5.1 változathoz készült, fórumokban visszajelzés hogy működik.
Most teszt, hogy ha a 4.19 nem is fordul elő, akkor egyből az 5.x esetén mi történik...


Vissza: “AVR és fejlesztőlemeze”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 0 vendég