Programfeltöltési hiba

Processing/Wiring (illetve C) nyelvű programozási fogások, tippek. (AVR-Duino, Arduino, EthDuino, Diecimila, Severino, Nano, LilyPad)
Avatar
rostasc3
Biztosítékgyilkos
Hozzászólások: 52
Csatlakozott: 2009. október 20. kedd, 6:00

HozzászólásSzerző: rostasc3 » 2012. szeptember 25. kedd, 8:50

Az enyémen még a régi van.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9989
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2012. szeptember 25. kedd, 9:27

Akkor sima ISP10, A sorosporti 9-es csatlakozó is elég hozzá...

Avatar
rostasc3
Biztosítékgyilkos
Hozzászólások: 52
Csatlakozott: 2009. október 20. kedd, 6:00

HozzászólásSzerző: rostasc3 » 2012. október 4. csütörtök, 7:27

Beforrasztottam az ISP és az ftdi melletti csatlakozót, rádugtam a szalagkábelt, elolvastam a fent említett cikket és minden működik!
Köszönöm a segítséget!

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9989
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2012. október 4. csütörtök, 18:54

Éjjel, megsütött chip problematikája? :P

Avatar
rostasc3
Biztosítékgyilkos
Hozzászólások: 52
Csatlakozott: 2009. október 20. kedd, 6:00

HozzászólásSzerző: rostasc3 » 2012. október 5. péntek, 9:23

Nem aggódtam halálra magam, bíztam abban, hogy semmi baj nem lesz, és a bootloader feltöltés is menni fog :-).
Mentőöv is volt, a tervezett dologhoz úgyis kicsi a 168-as...
Tovább tartott mire szereztem tüskesort meg kábelt (vidék).

Avatar
volkov
DrótVégénSzéndarab
Hozzászólások: 45
Csatlakozott: 2012. november 10. szombat, 7:00

HozzászólásSzerző: volkov » 2012. december 10. hétfő, 21:12

Sziasztok!

Ma elővettem az arduino-mat, megpróbáltam feltölteni rá egy új programot, de nem megy...

Egy serial port-os program volt/van rajta, ha adok neki áramot, akkor usb kábelen serial monitorral jön az info belőle, de ha megprobálok rá feltölteni vmit, akkor a D13 villan párat, majd a TX kezd el villogni, a feltöltés meg megáll.
Probáltam reset-tel és egyből feltöltés, de az se jó.

Ilyenkor mi a rák van? 8O

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9989
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2012. december 10. hétfő, 21:16

A board-ból nem a megfelelő van kiválasztva....

Avatar
volkov
DrótVégénSzéndarab
Hozzászólások: 45
Csatlakozott: 2012. november 10. szombat, 7:00

HozzászólásSzerző: volkov » 2012. december 10. hétfő, 21:35

Robert írta:A board-ból nem a megfelelő van kiválasztva....


Basszus, lesül a pofám, de tényleg ez volt a gond... :oops:
Fel se merült bennem, hogy magától elállítódik.
De átugrott UNO-ra vhogy...
Fura :roll:

Minden esetre köszönöm a gyors választ!

(már féltem, hogy kinyírtam a "serial" programmal, mert olvastam most olyat külföldi fórumon, hogy elég egy sz@r végtelen ciklus: utána nyista usb amíg fut a program :P)

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9989
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

HozzászólásSzerző: Robert » 2012. december 10. hétfő, 21:48

Uno-ra akkor megy vissza, ha tobbfele Arduino keretrendszert is hasznalsz... Összevesznek és ez a döntetlen állás....


Ha az USB-t foglalhatja valami, így max az Arduino sw nem fér hozzá. Ilyen pl.: Arduino hw-ből csinálj soros egeret. A hülye Win felismeri :P és tologatja is a cursort - eőször nem olyan vicces, hogy a vezérlőpultban egy Serial Mouse néz vissza.... :P

Avatar
willmenn
Biztosítékgyilkos
Hozzászólások: 61
Csatlakozott: 2012. július 14. szombat, 6:00
Tartózkodási hely: Oroszlány

Re: Programfeltöltési hiba

HozzászólásSzerző: willmenn » 2013. március 29. péntek, 19:30

Probálom leforditani egy programot, de már ellenörzéskor csak simán
Hiba a forditás során Üzenetet kapok.
Pirossal az üzenő sorba:
core.a(main.cpp.o): In function `main':
D:\Scanner\arduino-1.0.4\hardware\arduino\cores\arduino/main.cpp:11: undefined reference to `setup'
D:\Scanner\arduino-1.0.4\hardware\arduino\cores\arduino/main.cpp:14: undefined reference to `loop'


Valaki meg tudná mondani, hogy mi a hiba?
Előre is köszi!
Nincs meg a kellő jogosultságod a hozzászóláshoz csatolt állományok megtekintéséhez.

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9989
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Programfeltöltési hiba

HozzászólásSzerző: Robert » 2013. március 29. péntek, 19:56

Arduino törlés, újratelepítés.... :(

Avatar
willmenn
Biztosítékgyilkos
Hozzászólások: 61
Csatlakozott: 2012. július 14. szombat, 6:00
Tartózkodási hely: Oroszlány

Re: Programfeltöltési hiba

HozzászólásSzerző: willmenn » 2013. március 29. péntek, 20:13

Sajnos ugyan az a jelenség újratelep után is!
Egyéb ötlet?

Egyszerűbb programokat minden további nélkül fordít feltölt!

Avatar
Robert
Elektronbűvölő
Hozzászólások: 9989
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Programfeltöltési hiba

HozzászólásSzerző: Robert » 2013. március 29. péntek, 20:22

Arduino-0023 alatt fordítani....

Avatar
willmenn
Biztosítékgyilkos
Hozzászólások: 61
Csatlakozott: 2012. július 14. szombat, 6:00
Tartózkodási hely: Oroszlány

Re: Programfeltöltési hiba

HozzászólásSzerző: willmenn » 2013. március 31. vasárnap, 8:05

Úgyan az minden!

Avatar
kapu48
Elektronbűvölő
Hozzászólások: 3321
Csatlakozott: 2008. augusztus 29. péntek, 6:00
Tartózkodási hely: Újkígyós

Re: Programfeltöltési hiba

HozzászólásSzerző: kapu48 » 2013. március 31. vasárnap, 8:32

Húzd ki a PC-d csatlakozóját a konektórból, és dugd vissza 180° elfordítva!
:lol:


Vissza: “Arduino / C-nyelvű programozás (AVR-Duino, EthDuino, Arduino, Diecimila)”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 0 vendég