DFU-mode?

Forrasztópákákról, kemencéről, ónokról, pasztákról, fluxokról és a fogásokról.....
Válasz küldése
Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

DFU-mode?

Hozzászólás Szerző: szuperp »

Úgy néz ki mintha meghalt volna az USB illesztő az aruino mega 2560 rev3.
azt olvasom, hogy DFU-módban kell ilyenkor a firmware-t frissíteni...
de sajnos nem tudom, hogy kell...R2-höz találtam leírást, de az r3 más...

dfu-programmer: no device present.
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: DFU-mode?

Hozzászólás Szerző: Robert »

Ugyanaz a 2 firmware és chip USB illesztés oldalon.
ATMega8U2 ill ATMega16U2 lehet.
R1: mega8U2;
R2: Mega16U2;
R3: Mega16U2 és a központi chip SCL/SDA és a I/O fesz + NC lábak kerültek kivezetésre.
Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

Re: DFU-mode?

Hozzászólás Szerző: szuperp »

Sajnos nem tudom, hogy kell dfu modba rakni...
Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

Re: DFU-mode?

Hozzászólás Szerző: szuperp »

lehet, hogy nem is kell... ISP-n keresztül tudom programozni... felmegy a program hiba nélkül, de nem működik...
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: DFU-mode?

Hozzászólás Szerző: Robert »

Nem azt írtad, hogy van leírásod?
A forraszjumpert amivel DFU/Normál módba váltasz - felforrasztod. (gyak: Bootloader vs normál futás)
Tápra dugásnál a DFU indul el.


Ha ISPvel programoztad, akkor a fusebiteket is ehhez á kell igazítani!
Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

Re: DFU-mode?

Hozzászólás Szerző: szuperp »

most kezdem érteni...
nem FTDI chip illeszti a chippet, hanem egy 16U2 mikrokontroller...
valószínüleg ezt kellene újra flash-elni, mert senki semmit nem lát az USB-re történő csatlakozáskor...
viszont azt írják, hogy, ha DFU módba rakom, akkor látszania kéne...

sajnos egy normális leírást sem találtam hozzá...

azt írtad (és ezt eddig sehol nem láttam), hogy tápradugásnál kéne DFU módba lépnie, most kipróbáltam ezt is, de így sem látszik az eszközkezelőben...lehet meghalt a cucc?
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: DFU-mode?

Hozzászólás Szerző: Robert »

Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

Re: DFU-mode?

Hozzászólás Szerző: szuperp »

Köszönöm... a második kettő megvolt, csak elhasaltam azon, hogy a mac-en nem tudom használni az avrdude-ot...
valamiért mindig ezt írja:

Kód: Egész kijelölése

dyld: Library not loaded: /usr/local/lib/libusb-0.1.4.dylib
  Referenced from: /usr/local/bin/avrdude
  Reason: image not found
pedig az arduino keretrendszer is avrdude-ot hasznl, szóval nem értem.... (raktam fel már macport-ot, libusb-t, xcode-ot és még az isten tudja miket...), szóval most átültem egy windows 7-hez...
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: DFU-mode?

Hozzászólás Szerző: Robert »

A DFU / bootloader illesztő nem ment fel.
Arduino esetén soros illesztőd van...

A dude erre épül rá rétegben.
Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

Re: DFU-mode?

Hozzászólás Szerző: szuperp »

most megcsináltam az első leírás alapján a firmware frissítést, elvileg megy is, de nem jelenik meg az eszköz kezelőben... lehet megadta magát a chip.. elvileg a DFU módba úgy rakom be, hogy a reset lábat leföldelem és úgy adok rá tápot? akkor már látszania kéne az eszközkezelőben?
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: DFU-mode?

Hozzászólás Szerző: Robert »

Igen. RESET lehúzva GNDre: A chip nem fut!
HWB lábat kell lekötni és a RESET elengedése _után_ indul a chip DFU módban!
Avatar
szuperp
Bitmanipulátor
Hozzászólások: 116
Csatlakozott: 2012. november 17. szombat, 7:00

Re: DFU-mode?

Hozzászólás Szerző: szuperp »

Ez őrület... hogy mindig van még valami... és hogy kössem le a hwb lábat? mert természetesen minden leírás a neten arduino UNO-hoz van...
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: DFU-mode?

Hozzászólás Szerző: Robert »

Válasz küldése