Arduino nano panel hiba

Avatar
koskalajos
Újonc
Újonc
Hozzászólások: 4
Csatlakozott: 2011. december 17. szombat, 7:00

Arduino nano panel hiba

Hozzászólás Szerző: koskalajos »

Üdvözlök mindenkit a fórumon!
Szeretnék segítséget kérni,hátha valaki találkozott ezzel a hibával.
Arduino nano lap, A beleírt program gyönyörűen megy csak nem tudok változtatni rajta.
Amikor összekapcsolom a számítógéppel fel kéne ismernie a portot amit eddig meg is tett.
Tehát összekapcsolom a géppel 1, a power led félerővel világít
2, 5V meg van az USB bejövő lábain a nyák felől
3, a ch340 ic lábain már csak 2,1V mérhető.
Lehet hogy a programozásnál rajta maradt a WS2812 tápfeszültsége és az esetleg kinyomta az USB tápfeszt?
Hogy kizárjam a hibákat van egy másik nano panel az hibátlanul működik.
Köszönettel,
Koska Lajos
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino nano panel hiba

Hozzászólás Szerző: Robert »

Az 5V lábon hány volt mérhető (5V és GND közt). Ha USB-ről jár, akkor ~4.6...4.7V-ot kell mérni rajta.
WS2812 tápfeszültégét a 5Vra átkötni?
http://www.tavir.hu - a gazda :)
Avatar
koskalajos
Újonc
Újonc
Hozzászólások: 4
Csatlakozott: 2011. december 17. szombat, 7:00

Re: Arduino nano panel hiba

Hozzászólás Szerző: koskalajos »

Kedves Róbert!
Nincs külső táp! Az USB csatlakozón bejövő feszültség kerek 5V, a sz.gép minden kimenetén ennyi.
Egy nap pihenés után annyi változott hogy most a power led rendesen világít, csatlakoztatom a nanot felismeri a portot de kb 5mp múlva eldobja.
De van úgy is hogy megtartja a portot, és a feltöltésnél írja ki hogy nincs port de az eszközöknél ott van és él.
Ha nem jutunk vele előre akkor lehet hogy valami végzetes hiba történhetett a lappal.
Ha sikerül egyeztetni akkor elmennék a szemüvegemért és akkor vennék egy új lapot, amit a múltkor vettem Önnél az jól működik.
Üdvözlettel,
Koska Lajos
Avatar
Robert
Elektronbűvölő
Hozzászólások: 10122
Csatlakozott: 2005. december 9. péntek, 7:00
Tartózkodási hely: Budapest
Kapcsolat:

Re: Arduino nano panel hiba

Hozzászólás Szerző: Robert »

Az ha eldobja - az túlterhelésre utal...
Vagy meghalálozott stabilizátorra vagy a tápellátási hibára.

A kiválasztott portot ha eldobja és utána marad kiválasztva - a tapasztalat szerint - nem tudja használni/feltölteni rá.
http://www.tavir.hu - a gazda :)
Avatar
koskalajos
Újonc
Újonc
Hozzászólások: 4
Csatlakozott: 2011. december 17. szombat, 7:00

Re: Arduino nano panel hiba

Hozzászólás Szerző: koskalajos »

Kedves Róbert!
Valószínű igaza lehet a táppal kapcsolatban, de van ott egy schottky dióda ami felelős az USB és a külső táp váltásáért.
Vagy a dióda vagy a feszszab mehetett ki. Még ezt nem néztem, de azt már igen hogy a Ch340 ic feszültség lábain ahol 5V-nak kéne lennie, ott csak 2,7V mérhető. Hát ebből gondolom hogy a táp körül lehet a hiba.
Üdvözlettel,
Koska Lajos
Avatar
koskalajos
Újonc
Újonc
Hozzászólások: 4
Csatlakozott: 2011. december 17. szombat, 7:00

Re: Arduino nano panel hiba

Hozzászólás Szerző: koskalajos »

Kedves Róbert!
Megoldódott a probléma a schottky dióda hibásodott meg, cserélve lett minden ok.
Lehet programozni, fel is megy! Megy mint régen.
Üdvözlettel,
Koska Lajos
Válasz küldése